华为-H3C交换机链路聚合配置--link-aggregation

2021年09月15日 阅读数:2
这篇文章主要向大家介绍华为-H3C交换机链路聚合配置--link-aggregation,主要内容包括基础应用、实用技巧、原理机制等方面,希望对大家有所帮助。

1,链路聚合技术原理网络

         Eth-Trunk( 链路聚合技术 )做为一种捆绑技术,能够把多个独立的物理接口绑定在一块儿做为一个大带宽的逻辑接口使用,这样既不用替换接口板也不会浪费IP地址资源。负载均衡

  • Eth-Trunk是一种将多个以太网接口捆绑成一个逻辑接口的捆绑技术。
  • Eth-Trunk链路聚合模式:
  • 手工负载分担模式;
  • LACP模式。
  • LACP模式也称为M:N模式,其中M条链路处于活动状态转发数据,N条链路处于非活动状态做为备份链路。

 

  • 华为-H3C交换机链路聚合配置--link-aggregation_网络
  • 在LACP模式的Eth-Trunk中加入成员接口后,这些接口将向对端通告本身的系统优先级、MAC地址、接口优先级、接口号等信息。对端接收到这些信息后,将这些信息与自身接口所保存的信息比较以选择可以聚合的接口,双方对哪些接口可以成为活动接口达成一致,肯定活动链路。ide

    在两端设备中选择系统LACP优先级较高的一端做为主动端,若是系统LACP优先级相同则选择MAC地址较小的一端做为主动端。spa

    系统LACP优先级的值越小,则优先级越高,缺省状况下,系统LACP优先级的值为32768。3d

    接口LACP优先级的值越小,则优先级越高。若是接口LACP优先级相同,接口ID(接口号)小的接口被优先选为活动接口。blog

    接口LACP优先级是为了区别同一个Eth-Trunk中的不一样接口被选为活动接口的优先程度,优先级高的接口将优先被选为活动接口。华为-H3C交换机链路聚合配置--link-aggregation_H3C_02
  • LACP抢占延时设置:接口

    LACP抢占发生时,处于备用状态的链路将会等待一段时间后再切换到转发状态,这就是抢占延时。配置抢占延时是为了不因为某些链路状态频繁变化而致使Eth-Trunk数据传输不稳定的状况。ip

    如图所示,Port1因为链路故障切换为非活动接口,此后该链路又恢复了正常。若系统使能了LACP抢占并配置了抢占延时,Port1从新切换回活动状态就须要通过抢占延时的时间。资源

    开启抢占功能的场景:it

    pPort1接口出现故障然后又恢复正常。当接口Port1出现故障时被Port3所取代,若是在Eth-Trunk接口下未使能抢占,则故障恢复时Port1将处于备份状态;若是使能了LACP抢占,当Port1故障恢复时,因为接口优先级比Port3高,将从新成为活动接口,Port3再次成为备份接口。

    p若是但愿Port3接口替换Port一、Port2中的一个接口成为活动接口,能够将Port3的接口LACP优先级调高,但前提条件是已经使能了LACP抢占功能。若是没有使能LACP抢占功能,即便将备份接口的优先级调整为高于当前活动接口的优先级,系统也不会进行从新选择活动接口的过程,也不切换活动接口。

    华为-H3C交换机链路聚合配置--link-aggregation_网络_03
  • 成员接口不能有IP地址等三层配置项,也不能够配置任何业务;

    成员接口不能配置静态MAC地址;

    Eth-Trunk接口不能嵌套,即成员接口不能是Eth-Trunk;

    一个以太网接口只能加入到一个Eth-Trunk接口,若是须要加入其余Eth-Trunk接口,必须先退出原来的Eth-Trunk接口;

    若是本地设备使用了Eth-Trunk,与成员接口直连的对端接口也必须捆绑为Eth-Trunk接口,两端才能正常通讯;

    Eth-Trunk有两种工做模式:二层工做模式和三层工做模式。Eth-Trunk的工做模式不影响成员链路的加入,例如,以太网接口既能够加入二层模式的Eth-Trunk,也能够加入三层模式的Eth-Trunk

2,配置命令

华为-H3C交换机链路聚合配置--link-aggregation_H3C_04

  • 建立Eth-Trunk接口并配置地址:

    interface Eth-Trunk1

     undo portswitch         //将接口转换为三层接口

     description “Core-R1 to Aggregate-SW3“ //描述信息,便于管理员了解接口对端所链接的设备

     ip address 192.168.1.254 255.255.255.0

    #

    interface Eth-Trunk2

     undo portswitch

     description "Core-R1 to Core-R2"

     ip address 192.168.12.1 255.255.255.0

  • 将物理接口添加入Eth-Trunk中:

    interface GigabitEthernet0/0/0

     eth-trunk 1

    interface GigabitEthernet0/0/1

     eth-trunk 1

    #

    interface GigabitEthernet1/0/0

     eth-trunk 2

    interface GigabitEthernet1/0/1

     eth-trunk 2

  • 使用二层互联,因此无需配置地址

    interface Eth-Trunk1

     description “Aggregate-SW3 to Core-R1“

  • lacp priority 0                                                       #配置LACP系统优先级

     

    mode lacp-static                                                   #选择链路聚合模式

  • trunkport GigabitEthernet 0/0/1 to 0/0/2          #能够直接在聚合口内直接加入端口
  • max active-linknumber 2                                      #最大活动链路
  • [GigabitEthernet0/0/1]lacp priority 1                 #接口优先级
  • lacp preempt enable                                             #开启抢占
  • lacp preempt delay 20                                          #抢占延迟20秒
  • load-balance src-dst-ip                                         #负载均衡

    interface Eth-Trunk2

     description “Aggregate-SW3 to Aggregate-SW4“

  • 将物理接口添加入Eth-Trunk中 

     

    interface Ethernet0/0/3

     eth-trunk 2

    interface Ethernet0/0/4

     eth-trunk 2
  • 华为-H3C交换机链路聚合配置--link-aggregation_华为_05

  • H3C 交换机配置连接聚合
  • 华为-H3C交换机链路聚合配置--link-aggregation_链路聚合_06
  • 三层链路聚合配置
    interface route-aggregation 2  
  • ip address 192.168.1.1 255.255.255.0
  • link-aggregation global load-sharing mode destination-ip   #ip地址进行负载分担
  • link-aggregation mode dynamic    #动态聚合模式
  • interface range g0/0/0 to g0/0/1
  • lacp mode passive
  • port link-aggregatio group 2