SpringBoot基础回顾-7

2021年05月05日 阅读数:6
这篇文章主要向大家介绍SpringBoot基础回顾-7,主要内容包括基础应用、实用技巧、原理机制等方面,希望对大家有所帮助。

## 2. SpringBoot原理深刻及源码剖析mysql

​       

传统的Spring框架实现一个Web服务,须要导入各类依赖JAR包,而后编写对应的XML配置文件等,相较而言,Spring Boot显得更加方便、快捷和高效。那么,Spring Boot究竟如何作到这些的呢?web

接下来分别针对Spring Boot框架的依赖管理、自动配置和执行流程进行深刻分析spring

### 2.1 依赖管理sql

​      问题:(1)为何导入dependency时不须要指定版本?数据库

​       

在Spring Boot入门程序中,项目pom.xml文件有两个核心依赖,分别是spring-boot-starter-parent和spring-boot-starter-web,关于这两个依赖的相关介绍具体以下:apache

**1.spring-boot-starter-parent依赖**json

在chapter01项目中的pom.xml文件中找到spring-boot-starter-parent依赖,示例代码以下:tomcat

```xml服务器

<!-- Spring Boot父项目依赖管理 -->session

      <parent>

              <groupId>org.springframework.boot</groupId>

              <artifactId>spring-boot-starter-parent<11./artifactId>

              <version>2.2.2.RELEASE</version>

              <relativePath/>

<!-- lookup parent from repository -->

      </parent>

```

​       

上述代码中,将spring-boot-starter-parent依赖做为Spring Boot项目的统一父项目依赖管理,并将项目版本号统一为2.2.2.RELEASE,该版本号根据实际开发需求是能够修改的   

​       

使用“Ctrl+鼠标左键”进入并查看spring-boot-starter-parent底层源文件,发现spring-boot-starter-parent的底层有一个父依赖spring-boot-dependencies,核心代码具体以下 

```xml

<parent>

      <groupId>org.springframework.boot</groupId>

      <artifactId>spring-boot-dependencies</artifactId>

      <version>2.2.2.RELEASE</version>

      <relativePath>../../spring-boot-dependencies</relativePath>

</parent>

```

继续查看spring-boot-dependencies底层源文件,核心代码具体以下:

```xml

<properties>

<activemq.version>5.15.11</activemq.version>

  ...

<solr.version>8.2.0</solr.version>

<mysql.version>8.0.18</mysql.version>

<kafka.version>2.3.1</kafka.version>

<spring-amqp.version>2.2.2.RELEASE</spring-amqp.version>

<spring-restdocs.version>2.0.4.RELEASE</spring-restdocs.version>

<spring-retry.version>1.2.4.RELEASE</spring-retry.version>

<spring-security.version>5.2.1.RELEASE</spring-security.version>

<spring-session-bom.version>Corn-RELEASE</spring-session-bom.version>

<spring-ws.version>3.0.8.RELEASE</spring-ws.version>

<sqlite-jdbc.version>3.28.0</sqlite-jdbc.version>

<sun-mail.version>${jakarta-mail.version}</sun-mail.version>

<tomcat.version>9.0.29</tomcat.version>

<thymeleaf.version>3.0.11.RELEASE</thymeleaf.version>

<thymeleaf-extras-data-attribute.version>2.0.1</thymeleaf-extras-data-attribute.version>

              ...

</properties>

```

  从spring-boot-dependencies底层源文件能够看出,该文件经过<properties>标签对一些经常使用技术框架的依赖文件进行了统一版本号管理,例如activemq、spring、tomcat等,都有与Spring Boot 2.2.2版本相匹配的版本,这也是pom.xml引入依赖文件不须要标注依赖文件版本号的缘由。

须要说明的是,若是pom.xml引入的依赖文件不是 spring-boot-starter-parent管理的,那么在pom.xml引入依赖文件时,须要使用<version>标签指定依赖文件的版本号。

(2)问题2: spring-boot-starter-parent父依赖启动器的主要做用是进行版本统一管理,那么项目运行依赖的JAR包是从何而来的?

**2.

spring-boot-starter-web依赖**

​ 

查看spring-boot-starter-web依赖文件源码,核心代码具体以下

```xml

<dependencies>

<dependency>

<groupId>org.springframework.boot</groupId>

<artifactId>spring-boot-starter</artifactId>

<version>2.2.2.RELEASE</version>

<scope>compile</scope>

</dependency>

<dependency>

<groupId>org.springframework.boot</groupId>

<artifactId>spring-boot-starter-json</artifactId>

<version>2.2.2.RELEASE</version>

<scope>compile</scope>

</dependency>

<dependency>

<groupId>org.springframework.boot</groupId>

<artifactId>spring-boot-starter-tomcat</artifactId>

<version>2.2.2.RELEASE</version>

<scope>compile</scope>

</dependency>

<dependency>

<groupId>org.springframework.boot</groupId>

<artifactId>spring-boot-starter-validation</artifactId>

<version>2.2.2.RELEASE</version>

<scope>compile</scope>

<exclusions>

<exclusion>

<artifactId>tomcat-embed-el</artifactId>

<groupId>org.apache.tomcat.embed</groupId>

</exclusion>

</exclusions>

</dependency>

<dependency>

<groupId>org.springframework</groupId>

<artifactId>spring-web</artifactId>

<version>5.2.2.RELEASE</version>

<scope>compile</scope>

</dependency>

<dependency>

<groupId>org.springframework</groupId>

<artifactId>spring-webmvc</artifactId>

<version>5.2.2.RELEASE</version>

<scope>compile</scope>

</dependency>

</dependencies>

```

从上述代码能够发现,spring-boot-starter-web依赖启动器的主要做用是提供Web开发场景所需的底层全部依赖

正是如此,在pom.xml中引入spring-boot-starter-web依赖启动器时,就能够实现Web场景开发,而不须要额外导入Tomcat服务器以及其余Web依赖文件等。固然,这些引入的依赖文件的版本号仍是由spring-boot-starter-parent父依赖进行的统一管理。

​       

Spring Boot除了提供有上述介绍的Web依赖启动器外,还提供了其余许多开发场景的相关依赖,咱们能够打开Spring Boot官方文档,搜索“Starters”关键字查询场景依赖启动器 

列出了Spring Boot官方提供的部分场景依赖启动器,这些依赖启动器适用于不一样的场景开发,使用时只须要在pox.xml文件中导入对应的依赖启动器便可。

须要说明的是,Spring Boot官方并非针对全部场景开发的技术框架都提供了场景启动器,例如数据库操做框架MyBatis、阿里巴巴的Druid数据源等,Spring Boot官方就没有提供对应的依赖启动器。为了充分利用Spring Boot框架的优点,在Spring Boot官方没有整合这些技术框架的状况下,MyBatis、Druid等技术框架所在的开发团队主动与Spring Boot框架进行了整合,实现了各自的依赖启动器,例如mybatis-spring-boot-starter、druid-spring-boot-starter等。咱们在pom.xml文件中引入这些第三方的依赖启动器时,切记要配置对应的版本号  。

***上了拉勾教育的《Java工程师高薪训练营》,作一下笔记。但愿拉勾能给我推到想去的公司,目标:字节!!***